2013-08-24 Sat

ブログを引越ししました。新しいブログもよろしくお願いします。
Heartfield - What’s wrong about feeling good?

NP_znItemFieldEXをNucleus 3.65に対応

個人的にNucleusには必須であると考えている2つのプラグイン、NP_CustomURLと、NP_znItemFIeldEX。この2つのプラグインがあれば、Nucleusでかなり自由にサイトを構築できます。
ただ、残念ながらこの2つのプラグインはNucleus 3.65では正常に動作しません。

ということを書いている間に、なんと「NP_CustomURL」はモデレータの方が対策してくれたみたいです。

バージョン3.65に適合するItem Templateはあるか教えてください (ページ 2) / プラグイン / Nucleus(JP)フォーラム

これはほんとにありがたいですね。時間を作って当サイトでも検証させていただきたいと思います。

で、もう一つの必須プラグイン「NP_znItemFIeldEX」ですが、作者さんのサイトが閉鎖されてしまったようでとても残念です。幸いこちらのサイトで修正方法が書かれています。

【Nucleus】3.65でznitemfieldexが動かない問題 知識Z(ゼータ)

コアファイルの修正は現在配布されているバージョンでは修正されているのかな?
NP_znItemFieldEXの修正該当箇所は他にもありますので、同じように修正すれば3.65でも問題なく動かすことができました。

いつ頃リリースされるのか不明ですが、Nucleus 4になると、プラグインの互換性がかなり厳しくなるそうです。僕もあまり利用されていないとはいえ、いくつかプラグインを作成しているので覚悟しておかねばなりませんね…

関連記事

Tag:

2013-08-24 Sat / Category - Nucleus / Comment - 3 / TrackBack - 0

「NP_znItemFieldEXをNucleus 3.65に対応」へのトラックバック

TrackBack URL:

「NP_znItemFieldEXをNucleus 3.65に対応」へのコメント

nomorewp wrote...

znitemfieldexのフィールドを検索対象にするNP_ExtensibleSearchが3.65だとダメですね。各プラグインで「$manager->notify〜」のところは修正してみたのですが、しれ〜っと指定フィールドを無視してくれちゃいます。
こういうことはあまり書きたくありませんが、Nucleusは3.41までがベストなのかな。

2013-09-03 Tue 15:47

nomorewp wrote...

NP_ExtensibleSearchでの指定フィールド検索できてました。スキン記載が間違えてただけでした、すいません。ただ、あの「ORDER BY score DESC」でのSQLエラーはMysql5がらみのものだと思いますが、なんか困りますね。

2013-09-06 Fri 11:49

pushman wrote...

nomorewpさん
すみません。なぜかコメント通知機能が動いていない模様で…
色々な情報ありがとうございます。

Nucleus管理画面はとっつきにくいですが、カスタマイズしやすいCMSだと思います。
ただ、3.65は互換性考えるとまだ実践投入できないですね。
ということで、僕は3.64を使用しています。

2013-09-25 Wed 10:35





このページの先頭に戻る

Copyright 2013 - Heartfield